Кръчмата > Задайте въпрос

Apache Virtual Hosts

(1/1)

Dantcho:
Здравейте,

Имам един Apache сървър на Windows 10. Сичко изглежда работи освен виртуалните хостове.

Като отворя todo.local ми излиза директорията на localhost.

Ето конфиг файловете:
https://gist.github.com/DantchoLV9/7f9f7ed180a403a301951a333d9166ce

Ако някой може да ми каже къде е проблема ще съм благодарен.

black:
За те насочва към желания хост защо нередактираш следните редове:
127.0.0.1   mylittleproject.local
127.0.0.1   todo.local
където се задават ип и хост?

Dantcho:

--- Цитат на: black в 15 Май 2019, 19:11:51 ---За те насочва към желания хост защо нередактираш следните редове:
127.0.0.1   mylittleproject.local
127.0.0.1   todo.local
където се задават ип и хост?

--- Край на цитат ---

Ако имаш на предвид хост файла ето го: (Също го има и в гиста на линка)

--- Код: ---
# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
# 127.0.0.1       localhost
# ::1             localhost

127.0.0.1 mylittleproject.local
127.0.0.1 todo.local


--- Край на кода ---

Вече съм направил нужните редиректи.

Dantcho:
Днеска отворих localhost и гледам няма нищо. После отворих един от виртуалните хостове и се оказа, че той работи.

Бих споделил как реших проблема, но и аз не знам тъй като не съм пипал нищо от както пуснах тази тема. Мислех си нещо да не се е кешнало но бях пробвал с друг браузар и с рестарт на цялата машината, но никакъв резултат.

Единственото нещо което се сещам е да не съм рестартирал Apache както трябва.

Се пак мерси на хората който искаха помогнат. Сега всичко си работи.

Навигация

[0] Списък на темите

Премини на пълна версия